MUX VLAN چیست؟ (قسمت دوم)

توسط

تو این قسمت دو سناریوی مختلف رو اجرا میکنیم تا تنظیمات مورد نیاز برای شما ملموس تر بشه. واقعا انجام تنظیماتش کار خاصی نداره.

در صورتی که در مورد MUX Vlan اطلاعاتی ندارید میتوانید به قسمت اول آموزش مراجعه نمایید.

این آموزش بخشی از آموزش های دوره ی HCNP می باشد. شما می توانید برای تست کدها در محیط های آموزشی از نرم افزار لابراتوار هواوی یعنی eNSP استفاده نمایید.

 

سناریوی اول: اجرا بر روی سویچ Access

در این سناریو قصد داریم کاربران رو به دو دسته تقسیم کنیم. دسته اول گروهی که میخواهیم با همدیگر و سرور در ارتباط باشند؛ دسته ی دوم گروهی که میخواهیم فقط با سرور در ارتباط باشند. نحوه ی این ارتباطات در شکل زیر نشان داده شده است.

 

VLAN های شماره 2، 3 و چهار را بسازید:

<HUAWEI> 

system-view


[HUAWEI] 

sysname Switch


[Switch] 

vlan batch 2 3 4

یک Group VLAN و یک Separate VLAN بسازید:

[Switch] 

vlan 2


[Switch-vlan2] 

mux-vlan


[Switch-vlan2] 

subordinate group 3


[Switch-vlan2] 

subordinate separate 4


[Switch-vlan2] 

quit

اینترفیس ها را به VLAN ها اضافه کنید و MUX VLAN را بر روی اینترفیس ها فعال سازید.

[Switch] 

interface gigabitethernet 0/0/1


[Switch-GigabitEthernet0/0/1] 

port link-type access


[Switch-GigabitEthernet0/0/1] 

port default vlan 2


[Switch-GigabitEthernet0/0/1] 

port mux-vlan enable vlan 2


[Switch-GigabitEthernet0/0/1] 

quit


[Switch] 

interface gigabitethernet 0/0/2


[Switch-GigabitEthernet0/0/2] 

port link-type access


[Switch-GigabitEthernet0/0/2] 

port default vlan 3


[Switch-GigabitEthernet0/0/2] 

port mux-vlan enable vlan 3


[Switch-GigabitEthernet0/0/2] 

quit


[Switch] 

interface gigabitethernet 0/0/3


[Switch-GigabitEthernet0/0/3] 

port link-type access


[Switch-GigabitEthernet0/0/3] 

port default vlan 3


[Switch-GigabitEthernet0/0/3] 

port mux-vlan enable vlan 3


[Switch-GigabitEthernet0/0/3] 

quit


[Switch] 

interface gigabitethernet 0/0/4


[Switch-GigabitEthernet0/0/4] 

port link-type access


[Switch-GigabitEthernet0/0/4] 

port default vlan 4


[Switch-GigabitEthernet0/0/4] 

port mux-vlan enable vlan 4


[Switch-GigabitEthernet0/0/4] 

quit


[Switch] 

interface gigabitethernet 0/0/5


[Switch-GigabitEthernet0/0/5] 

port link-type access


[Switch-GigabitEthernet0/0/5] 

port default vlan 4


[Switch-GigabitEthernet0/0/5] 

port mux-vlan enable vlan 4


[Switch-GigabitEthernet0/0/5] 

quit

برای تایید تنظیمات و تست آنها در نظر داشته باشید که سرور، هاستهای B، C، D و E در یک ساب نت هستند. سرور با هاستهایی که اعلام شد می تواند ارتباط لایه دو برقرار کند. هاست B و C می توانند ارتباط لایه دو با یکدیگر برقرار کنند. اما هاست D و E نمی توانند. همچنین هاست B و C نمی توانند با E و D ارتباط لایه دو داشته باشند. تنظیمات نهایی سویچ به صورت زیر می باشد:

# sysname Switch # vlan batch 2 to 4 # vlan 2 mux-vlan subordinate separate 4  subordinate group 3 # interface GigabitEthernet0/0/1 port link-type access port default vlan 2  port mux-vlan enable vlan 2 # interface GigabitEthernet0/0/2 port link-type access port default vlan 3 port mux-vlan enable vlan 3 # interface GigabitEthernet0/0/3 port link-type access port default vlan 3 port mux-vlan enable vlan 3 # interface GigabitEthernet0/0/4 port link-type access port default vlan 4 port mux-vlan enable vlan 4 # interface GigabitEthernet0/0/5 port link-type access port default vlan 4 port mux-vlan enable vlan 4 # return

سناریوی دوم: اجرا بر روی سویچ Aggregation

 

در ابتدا اقدام به ساخت VLANهای 2، 3 و 4 و همچنین VLANIF2 بر روی سویچ یک می کنیم. از آدرس VLANIF2 به عنوان گیت وی برای ارتباط هاست ها و سرور استفاده میکنیم:

<HUAWEI> system-view [HUAWEI] sysname Switch1 [Switch1] vlan batch 2 3 4 [Switch1] interface vlanif 2 [Switch1-Vlanif2] ip address 192.168.100.100 24 [Switch1-Vlanif2] quit

یک Group VLAN و یک Separate VLAN بسازید:

[Switch1] vlan 2 [Switch1-vlan2] mux-vlan [Switch1-vlan2] subordinate group 3 [Switch1-vlan2] subordinate separate 4 [Switch1-vlan2] quit

اینترفیسها را به VLAN اضافه کنید و MUX VLAN را فعال کنید:

[Switch1] interface gigabitethernet 0/0/2 [Switch1-GigabitEthernet0/0/2] port link-type trunk [Switch1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 [Switch1-GigabitEthernet0/0/2] port mux-vlan enable vlan 2 [Switch1-GigabitEthernet0/0/2] quit [Switch1] interface gigabitethernet 0/0/3 [Switch1-GigabitEthernet0/0/3] port link-type trunk [Switch1-GigabitEthernet0/0/3] port trunk allow-pass vlan 3 [Switch1-GigabitEthernet0/0/3] port mux-vlan enable vlan 3 [Switch1-GigabitEthernet0/0/3] quit [Switch1] interface gigabitethernet 0/0/4 [Switch1-GigabitEthernet0/0/4] port link-type trunk [Switch1-GigabitEthernet0/0/4] port trunk allow-pass vlan 3 [Switch1-GigabitEthernet0/0/4] port mux-vlan enable vlan 3 [Switch1-GigabitEthernet0/0/4] quit [Switch1] interface gigabitethernet 0/0/5 [Switch1-GigabitEthernet0/0/5] port link-type trunk [Switch1-GigabitEthernet0/0/5] port trunk allow-pass vlan 4 [Switch1-GigabitEthernet0/0/5] port mux-vlan enable vlan 4 [Switch1-GigabitEthernet0/0/5] quit [Switch1] interface gigabitethernet 0/0/6 [Switch1-GigabitEthernet0/0/6] port link-type trunk [Switch1-GigabitEthernet0/0/6] port trunk allow-pass vlan 4 [Switch1-GigabitEthernet0/0/6] port mux-vlan enable vlan 4 [Switch1-GigabitEthernet0/0/6] quit

به دلیل اینکه اضافه نمودن VLANها در قسمت قبلی توضیح داده شده است، از توضیح مجدد آن پرهیز میکنیم.

برای تست ارتباطات شبکه، سرور باید با تمام هاست ها بتواند ارتباط لایه دو برقرار کند. هاست B و C ارتباط لایه دو دارند. هاست D و E نباید بتوانند با همدیگر ارتباط برقرار کنندد. هاست های B و C با هاستهای D و E نباید بتوانند ارتباط لایه دو برقرار کنند. در اینصورت تنطیمات شما درست انجام شده است.

 

در نهایت، تنظیمات نهایی سویچ به شرح ذیل می باشد:

# sysname Switch1 # vlan batch 2 to 4 # vlan 2 mux-vlan subordinate separate 4  subordinate group 3 # interface Vlanif2  ip address 192.168.100.100 255.255.255.0  # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 2  port mux-vlan enable vlan 2 # interface GigabitEthernet0/0/3 port link-type trunk port trunk allow-pass vlan 3 port mux-vlan enable vlan 3 # interface GigabitEthernet0/0/4 port link-type trunk port trunk allow-pass vlan 3 port mux-vlan enable vlan 3 # interface GigabitEthernet0/0/5 port link-type trunk port trunk allow-pass vlan 4 port mux-vlan enable vlan 4 # interface GigabitEthernet0/0/6 port link-type trunk port trunk allow-pass vlan 4 port mux-vlan enable vlan 4 # return

در نهایت همانطور که مشاهده نمودید تنظیمات MUX VLAN بسیار ساده اما کارامد می باشد. در صورتی که تابحال از این تکنولوژی استفاده نمودید و یا حتی قصد دارید آن را پیاده سازی نمایید، در قسمت نظرات برای ما بنویسید و تجریبات خود را به اشتراک بگذارید.

 

 

 

 

You may also like